<!DOCTYPE html>
<!--[if lt IE 9 ]><html lang="en" class="no-js ie8"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<head>
<script>
        window.ajaxPath = 'https://skift.com/wp-admin/admin-ajax.php';
    </script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal</title>
<meta name="description" content="Selina, a hospitality brand, said on Thursday it would go public via a merger with a SPAC at an approximately $1.2 billion valuation" />
<link rel="canonical" href="https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal" />
<meta property="og:description" content="Selina, a hospitality brand, said on Thursday it would go public via a merger with a SPAC at an approximately $1.2 billion valuation" />
<meta property="og:url" content="https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/" />
<meta property="og:site_name" content="Skift" />
<meta property="article:publisher" content="https://www.facebook.com/Skiftnews" />
<meta property="article:published_time" content="2021-12-02T15:05:00+00:00" />
<meta property="article:modified_time" content="2021-12-02T16:28:08+00:00" />
<meta property="og:image" content="https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz-.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@skift" />
<meta name="twitter:site" content="@skift" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Sean O'Neill" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://skift.com/#organization","name":"Skift","url":"https://skift.com/","sameAs":["https://www.facebook.com/Skiftnews","https://www.instagram.com/skiftnews/?hl=en","https://www.linkedin.com/company/skift/","https://www.youtube.com/channel/UCJXw0BFh90eeJlg3YMLYd2Q?reload=9","https://twitter.com/skift"],"logo":{"@type":"ImageObject","@id":"https://skift.com/#logo","inLanguage":"en-US","url":"https://skift.com/wp-content/uploads/2018/04/logo.png","contentUrl":"https://skift.com/wp-content/uploads/2018/04/logo.png","width":"419","height":"157","caption":"Skift"},"image":{"@id":"https://skift.com/#logo"}},{"@type":"WebSite","@id":"https://skift.com/#website","url":"https://skift.com/","name":"Skift","description":"Travel News, Airline News, Hotel News &amp; Tourism News","publisher":{"@id":"https://skift.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://skift.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#primaryimage","inLanguage":"en-US","url":"https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz-.jpg","contentUrl":"https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz-.jpg","width":1200,"height":800,"caption":"Selina Huaraz"},{"@type":"WebPage","@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#webpage","url":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/","name":"Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal","isPartOf":{"@id":"https://skift.com/#website"},"primaryImageOfPage":{"@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#primaryimage"},"datePublished":"2021-12-02T15:05:00+00:00","dateModified":"2021-12-02T16:28:08+00:00","description":"Selina, a hospitality brand, said on Thursday it would go public via a merger with a SPAC at an approximately $1.2 billion valuation","breadcrumb":{"@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/"]}]},{"@type":"BreadcrumbList","@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://skift.com/"},{"@type":"ListItem","position":2,"name":"Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal"}]},{"@type":"NewsArticle","@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#article","isPartOf":{"@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#webpage"},"author":{"@id":"https://skift.com/#/schema/person/6e3cc11a66f78b3f8b4a3150ffb60c16"},"headline":"Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal","datePublished":"2021-12-02T15:05:00+00:00","dateModified":"2021-12-02T16:28:08+00:00","mainEntityOfPage":{"@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#webpage"},"wordCount":275,"publisher":{"@id":"https://skift.com/#organization"},"image":{"@id":"https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/#primaryimage"},"thumbnailUrl":"https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz-.jpg","keywords":["coworking","hospitality","hostels","ipo","selina","spacs","startups"],"articleSection":["Hospitality","Hotels","Startups"],"inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://skift.com/#organization"},"isAccessibleForFree":false,"hasPart":{"@type":"WebPageElement","isAccessibleForFree":false,"cssSelector":".post-copy"}},{"@type":"Person","@id":"https://skift.com/#/schema/person/6e3cc11a66f78b3f8b4a3150ffb60c16","name":"Sean O'Neill","description":"Sean O\u2019Neill is our first travel tech editor, focusing on business-to-business tech (not consumer tech). He was previously editor-in-chief of Tnooz and an expat in London. He now lives in the Philadelphia area. Please stop him before he begins another home improvement project.","url":"https://skift.com/author/sean-oneill/"}]}</script>

<link rel='dns-prefetch' href='//js.hs-scripts.com' />
<link rel='dns-prefetch' href='//use.typekit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='mediaelement-css' href='https://skift.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://skift.com/wp-includes/js/mediaelement/wp-mediaelement.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css' href='https://use.typekit.net/moj0gtk.css?ver=1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='icons-css' href='https://fonts.googleapis.com/icon?family=Material+Icons+Outlined&#038;ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='skift-main-css' href='https://skift.com/wp-content/themes/skift-2021/assets/styles/main.css?ver=17d724fad8f' type='text/css' media='all' />
<link rel='shortlink' href='https://skift.com/?p=456714' />
<meta name="generator" content="Site Kit by Google 1.42.0" /> 
<script type="text/javascript">
				var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);
			</script>

<script>
				(function() {
					var hbspt = window.hbspt = window.hbspt || {};
					hbspt.forms = hbspt.forms || {};
					hbspt._wpFormsQueue = [];
					hbspt.enqueueForm = function(formDef) {
						if (hbspt.forms && hbspt.forms.create) {
							hbspt.forms.create(formDef);
						} else {
							hbspt._wpFormsQueue.push(formDef);
						}
					}
					if (!window.hbspt.forms.create) {
						Object.defineProperty(window.hbspt.forms, 'create', {
							configurable: true,
							get: function() {
								return hbspt._wpCreateForm;
							},
							set: function(value) {
								hbspt._wpCreateForm = value;
								while (hbspt._wpFormsQueue.length) {
									var formDef = hbspt._wpFormsQueue.shift();
									if (!document.currentScript) {
										var formScriptId = 'leadin-forms-v2-js';
										hubspot.utils.currentScript = document.getElementById(formScriptId);
									}
									hbspt._wpCreateForm.call(hbspt.forms, formDef);
								}
							},
						});
					}
				})();
			</script>
<script>	
        window.myskUser = {"rid":"61a92d0e1b2e720018cdda94","is_subscriber":false,"signed_in":false,"authenticated":false,"has_access":true};	
        window.myskUrl = 'https://my.skift.com/';
    </script>

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/skift.com\/2021\/12\/02\/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal\/"},"headline":"Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal","url":"https:\/\/skift.com\/2021\/12\/02\/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal\/","thumbnailUrl":"https:\/\/skift.com\/wp-content\/uploads\/2021\/12\/Selina-Huaraz--150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/skift.com\/wp-content\/uploads\/2021\/12\/Selina-Huaraz--150x150.jpg"},"dateCreated":"2021-12-02T15:05:00Z","datePublished":"2021-12-02T15:05:00Z","dateModified":"2021-12-02T15:05:00Z","articleSection":"Hospitality","author":[{"@type":"Person","name":"Sean O'Neill"}],"creator":["Sean O'Neill"],"publisher":{"@type":"Organization","name":"Skift","logo":"https:\/\/skift.com\/wp-content\/uploads\/2016\/09\/cropped-logo-square-yellow.png"},"keywords":["coworking","hospitality","hostels","ipo","selina","spacs","startups"]}
</script>

<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1">

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-WZ9FZL8');</script>

<link rel="amphtml" href="https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/amp/"><link rel="icon" href="https://skift.com/wp-content/uploads/2016/09/cropped-logo-square-yellow-32x32.png" sizes="32x32" />
<link rel="icon" href="https://skift.com/wp-content/uploads/2016/09/cropped-logo-square-yellow-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://skift.com/wp-content/uploads/2016/09/cropped-logo-square-yellow-180x180.png" />
<meta name="msapplication-TileImage" content="https://skift.com/wp-content/uploads/2016/09/cropped-logo-square-yellow-270x270.png" />
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<script>
    window.pageData = {
        postId: 456714,
        categories: ["hospitality","hotels","travel-startups"],
        tags: ["coworking","hospitality","hostels","ipo","selina","spacs","startups-2"],
        author: {"author_bio":null,"id":343,"title":"","team":null,"img_id":false,"bio":"Sean O\u2019Neill is our first travel tech editor, focusing on business-to-business tech (not consumer tech). He was previously editor-in-chief of Tnooz and an expat in London. He now lives in the Philadelphia area. Please stop him before he begins another home improvement project.","email":"so@skift.com","twitter":null,"linkedin":null,"first_name":"Sean","last_name":"O'Neill","name":"Sean O'Neill","link":"https:\/\/skift.com\/author\/sean-oneill\/"},
        source: "Skift",
        sponsor: null    };
</script>
<noscript>
    <div id="js-warning">Javascript is required for this site to display correctly.</div>
</noscript>
<div id="header-container">
<div id="top-banner"></div>
<div class="header-wrap">
<div class="row overflow">
<div class="col-12 col-8-tablet col-4-mobile">
<input type="checkbox" class="mobile-only" id="mobile-trigger" />
<header id="header">
<div class="mobile-wrap">
<div class="logo">
<a href="https://skift.com">
<img src="https://skift.com/wp-content/themes/skift-2021/assets/img/logo/logo.svg" width="80" alt="Skift logo" />
</a>
</div>
<label for="mobile-trigger" class="mobile-sandwich mobile-only">
<div class="top-line"></div>
<div class="middle">
<div class="middle-line"></div>
<div class="middle-dot"></div>
</div>
<div class="bottom-line"></div>
</label>
</div>
<nav class="main-nav">
<div class="mobile-only mobile-search">
<div class="mobile-search-box">
<span class="material-icons-outlined">search</span>
<form id="mobile-search-form" action="https://skift.com" method="get">
<input type="search" name="s" placeholder="Search Skift.com" class="mobile-search-input" />
</form>
</div>
</div>
<ul>
<li class="has-sub-nav">
<input type="checkbox" class="mobile-only sub-menu-trigger" id="sub-nav_news" />
<div class="nav-item-wrap">
<label for="sub-nav_news" class="mobile-sub-nav-button">
<a href="https://skift.com/news/">
<span>News</span>
</a>
</label>
<div class="sub-menu">
<div class="sub-menu-wrap">
<div class="sub-menu-max-width">
<ul>
<li>
<div class="section-heading">Latest News</div>
<ul>
<li><a href="https://skift.com/news/">Latest News</a></li>
<li><a href="https://skift.com/coronavirus/">Coronavirus</a></li>
</ul>
</li>
 <li>
<div class="section-heading">News By Sector</div>
<ul>
<li><a href="https://skift.com/hotels/">Hotels</a></li>
<li><a href="https://skift.com/tourism/">Tourism</a></li>
<li><a href="https://skift.com/online-travel/">Online Travel</a></li>
<li><a href="https://skift.com/airlines/">Airlines</a></li>
<li><a href="https://skift.com/business-travel/">Business Travel</a></li>
<li class="see-all"><a href="https://skift.com/all-categories/">See All Sectors</a></li>
</ul>
</li>
<li>
<div class="section-heading">Stay Connected</div>
<ul>
<li><a href="https://skift.com/daily/">Skift Daily Newsletter</a></li>
<li><a href="https://skift.com/skift-daily-briefing/">Skift Daily Briefing</a></li>
<li><a href="https://airlineweekly.com/">Airline Weekly</a></li>
<li><a href="https://www.eventmanagerblog.com/">EventMB Updates</a></li>
<li><a href="https://dailylodgingreport.com">Daily Lodging Report</a></li>
</ul>
</li>
</ul>
<div class="promo">
<h3>Skift Pro</h3>
<p>Get exclusive stories and unlimited access to Skift.com news</p>
<a href="https://skift.com/pro/" class="btn btn-black">Subscribe Now</a>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="has-sub-nav">
<input type="checkbox" class="mobile-only sub-menu-trigger" id="sub-nav_events" />
<div class="nav-item-wrap">
<label for="sub-nav_events" class="mobile-sub-nav-button">
<a href="https://live.skift.com"><span>Events</span></a>
</label>
<div class="sub-menu two-columns">
<div class="sub-menu-wrap">
<div class="sub-menu-max-width">
<ul>
<li>
<div class="section-heading">Upcoming Events</div>
<ul>
<li class="has-date"><a href="https://live.skift.com/design-the-future/"><div class="date">Dec 9</div> Design the Future</a></li>
 <li class="has-date"><a href="https://skift.com/megatrends-2022/"><div class="date">Jan 19</div> Megatrends 2022</a></li>
<li class="see-all"><a href="https://live.skift.com">View All Events</a></li>
</ul>
</li>
<li>
<div class="section-heading">On-Demand Events</div>
<ul>
<li><a href="https://live.skift.com/destinations-sustainability-summit/">Tourism and Sustainability</a></li>
<li><a href="https://live.skift.com/short-term-rental-summit/">Short-Term Rentals and Outdoors</a></li>
<li><a href="https://live.skift.com/loyalty-subscription-summit/">Loyalty and Subscriptions</a></li>
<li><a href="https://live.skift.com/business-travel-future-of-work-summit/">Future of Work</a></li>
</ul>
</li>
</ul>
<div class="promo">
<h3>Skift Masterpass</h3>
<p>Access every online Skift event live or on demand</p>
<a href="https://live.skift.com/master-pass/" class="btn btn-black">Subscribe Now</a>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="has-sub-nav">
<input type="checkbox" class="mobile-only sub-menu-trigger" id="sub-nav_research" />
<div class="nav-item-wrap">
<label for="sub-nav_research" class="mobile-sub-nav-button">
<a href="https://research.skift.com"><span>Research</span></a>
</label>
<div class="sub-menu">
<div class="sub-menu-wrap">
<div class="sub-menu-max-width">
<ul>
<li>
<div class="section-heading">Latest Research</div>
<ul>
<li><a href="https://research.skift.com/report/the-state-of-hotel-payments-2021/">State of Hotel Payments</a></li>
<li><a href="https://research.skift.com/report/u-s-travel-tracker-july-2021-highlights/">July 2021 Travel Tracker</a></li>
<li><a href="https://skift.com/insight/the-state-corporate-travel-and-expense-2022/">Free Read: The State of Corporate Travel and Expense 2022</a></li>
<li><a href="https://research.skift.com/report/online-travel-agency-landscape-2021-southeast-asia/">Online Travel Agency Landscape</a></li>
</ul>
</li>
<li>
 <div class="section-heading">Research By Sector</div>
<ul>
<li><a href="https://research.skift.com/sectors/destinations/">Tourism</a></li>
<li><a href="https://research.skift.com/sectors/travel-tech/">Technology</a></li>
<li><a href="https://research.skift.com/sectors/hospitality/">Hospitality</a></li>
<li><a href="https://research.skift.com/sectors/consumer-habits/">Consumer Habits</a></li>
<li class="see-all"><a href="https://research.skift.com/sectors/">See All Sectors</a></li>
</ul>
</li>
<li>
<div class="section-heading">Featured Tools</div>
<ul>
<li><a href="https://research.skift.com/health-score/">Health Score</a></li>
<li><a href="https://research.skift.com/recovery/">Recovery Index</a></li>
<li><a href="https://research.skift.com/hotel-tech-benchmark/">Hotel Tech Benchmark</a></li>
</ul>
</li>
</ul>
<div class="promo">
<h3>Skift Research</h3>
<p>Access exclusive travel research, data insights, and surveys</p>
<a href="https://research.skift.com/subscribe/" class="btn btn-black">Subscribe Now</a>
</div>
</div>
</div>
</div>
</div>
</li>
<li>
<a href="https://skift.com/work-with-us/"><span>Advertise</span></a>
</li>
<li>
<a href="https://skift.com/get-access/"><div class="btn btn-yellow">Get Access</div></a>
</li>
</ul>
</nav>
<div class="right-side">
<div class="search-wrap hide-mobile">
<label for="search-desktop-trigger"><span class="material-icons-outlined">search</span></label>
<input type="checkbox" id="search-desktop-trigger" />
<form class="search-form" action="https://skift.com" method="get">
<input type="search" placeholder="Search Skift.com" name="s" class="search-box" />
</form>
</div>
<div class="user-wrap">
<a href="https://skift.com/auth/login/?redirect=https://skift.com/2021/12/02/selina-aims-to-go-public-at-1-2-billion-valuation-via-blank-check-deal/" rel="nofollow">
<span class="material-icons-outlined">person</span>
 Login
</a>
</div>
</div>
</header>
</div>
</div>
</div>
<div id="header-pad"></div>
</div>
<div id="article-wrapper">
<section class="meter-banner background-black text-white">
<div class="row offset-2 overflow">
<div class="col-8 col-8-tablet">
<div class="wrapper flex space-between align-items-center">
<div class="one-third indicator flex-grow-0">
<svg class="progress-ring" width="50" height="50">
<circle class="background-ring" r="21" cx="25" cy="25" />
<circle class="complete-ring" r="21" cx="25" cy="25" />
</svg>
<div class="text">2</div>
</div>
<div class="middle flex-grow-1">
<div class="bold hide-mobile"><p>Free stories left to read</p></div>
<p>
Subscribe to Skift Pro to get unlimited access to stories like these ($25/month)
</p>
</div>
<div class="right flex-grow-0">
<a href="https://skift.com/pro/" class="btn btn-yellow-outline btn-sm hide-mobile">Subscribe Now</a>
<a href="https://skift.com/pro/" class="mobile-subscribe-btn mobile-only"><div class="chevron-right"></div></a>
</div>
</div>
</div>
</div>
</section><article>
<section class="article-header">
<div class="row offset-1">
<div class="article-header-wrapper col-10 col-8-tablet col-4-mobile">
<div class="category">
<a href="https://skift.com/hospitality/">Hospitality</a>
</div>
<h1 class="headline">Selina Aims to Go Public at $1.2 Billion Valuation Via Blank Check Deal</h1>
<div class="byline">
<div class="byline-wrap">
<p class="author-name"><a href="https://skift.com/author/sean-oneill/">Sean O'Neill</a>, Skift</p>
<p class="post-date">Today at 10:05 AM EST</p>
</div>
</div>
</div>
</div>
</section><section class="article-photo">
<div class="row offset-1">
<div class="article-photo-wrapper col-10 col-8-tablet col-4-mobile">
<div class="fixed-ratio-img portrait">
<img src="https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz--1024x683.jpg" srcset="https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz--300x200.jpg 300w, https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz--1024x683.jpg 1024w, https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz--768x512.jpg 768w, https://skift.com/wp-content/uploads/2021/12/Selina-Huaraz-.jpg 1200w" alt="A view of a Selina property in Huaraz, Peru. Source: Skift" />
</div>
</div>
</div>
</section>
<section class="article-body">
<div class="row offset-1 overflow">
<div class="main-col col-10 col-8-tablet col-4-mobile">
<div class="left-rail">
<div class="article-wrapper">
<div class="article-skift-take">
<h2>Skift Take</h2>
<p class="take-copy">Kudos to Rafael Museri and Daniel Rudasevski who co-founded Selina in 2015 and brought the company to this point. But investors face a tricky decision about how to value this startup compared to traditional lodging groups.</p>
<p class="take-byline">
Sean O'Neill </p>
</div> <div class="social-share no-top-border no-top-padding">
<ul>
<li><div class="share-flag">Share</div></li>
<li><button class="share-btn facebook"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/facebook.svg" width="24" alt="Facebook Logo" /></button></li>
<li><button class="share-btn twitter"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/twitter.svg" width="24" alt="Twitter Logo" /></button></li>
<li><button class="share-btn linkedin"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/linkedin.svg" width="24" alt="LinkedIn Logo" /></button></li>
<li><button class="share-btn email"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/mail.svg" width="24" alt="Email icon" /></button></li>
</ul>
</div>
<div class="article-copy">
<p><a href="https://www.selina.com">Selina</a>, a hospitality brand focusing on millennials, said on Thursday it would go public via a merger with blank-check firm BOA Acquisition Corp in a transaction valuing the business at approximately $1.2 billion.</p>
<p>The deal includes a $70 million private investment in public equity, or PIPE, from South Light Capital, MORE Investment House, and Ronald Cohen. The merger is forecast to settle in the first half of 2022, with the company trading on the New York Stock Exchange under the symbol &#8220;SLNA.&#8221;</p>
<p>Selina manages 134 properties worldwide. The company has placed bets that trends in remote working, wellness-focused lifestyles, and subscription models will gain momentum over time. Last year <a href="https://skift.com/2020/10/05/selina-nabs-remote-year-in-bet-on-subscription-travel-for-digital-nomads/">it bought Remote Year</a>, a subscription-based remote working program.</p>
<p>The hospitality brand said it has sold more than 2,600 subscriptions for guests to hopscotch its properties and that Remote Year continued to increase its rate of subscription sales despite the pandemic.</p>
<p>Selina projects next year&#8217;s revenues will be $234 million. The company&#8217;s valuation is about 4 times its estimated enterprise value. That&#8217;s broadly in line with current valuations for major hotel groups. Intercontinental Hotels Group trades at a market capitalization of 3.8 times its revenue, while Hilton and Wyndham trade at 5.8 times their annualized revenue.</p>
<p>Selina CEO Rafael Museri has been one of the most forward-thinking leaders in hospitality. A prediction Museri made two years ago at <a href="https://live.skift.com">Skift Forum Europe</a> about how companies would have to allow all their employees the option of remote work within the next decade happened even sooner than he expected due to the pandemic.</p>
<p>See Selina&#8217;s investor presentation, below: And see <a href="https://skift.com/tag/selina/">Skift&#8217;s coverage of Selina, here</a>.</p>
<div class="wp-block-file"><object class="wp-block-file__embed" data="https://skift.com/wp-content/uploads/2021/12/selina-investor-presentation.pdf" type="application/pdf" style="width:100%;height:600px" aria-label="Embed of selina-investor-presentation."></object><a href="https://skift.com/wp-content/uploads/2021/12/selina-investor-presentation.pdf">selina-investor-presentation</a><a href="https://skift.com/wp-content/uploads/2021/12/selina-investor-presentation.pdf" class="wp-block-file__button" download>Download</a></div>
</div>
<div class="in-article-promo">
<div class="standard-promo width-content no-photo background-skift-pro">
<div class="wrapper">
<div class="content-inner">
<h3>Subscribe to Skift Pro</h3>
<div class="content"><p>Subscribe to Skift Pro to get unlimited access to stories like these ($30/month)</p>
</div> <a href="https://skift.com/pro/" class="btn btn-black btn-block" target="_blank" rel="noopener noreferrer">Subscribe Now</a>
</div>
</div>
</div>
</div>
</div>
<div class="footer-ad article-ad">
<div class="create-ad" data-size="640x480,300x250" data-mobilesize="300x250" data-slot="22809282/bottom"></div>
</div>
<div class="social-share ">
<ul>
<li><div class="share-flag">Share</div></li>
<li><button class="share-btn facebook"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/facebook.svg" width="24" alt="Facebook Logo" /></button></li>
<li><button class="share-btn twitter"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/twitter.svg" width="24" alt="Twitter Logo" /></button></li>
<li><button class="share-btn linkedin"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/linkedin.svg" width="24" alt="LinkedIn Logo" /></button></li>
<li><button class="share-btn email"><img src="https://skift.com/wp-content/themes/skift-2021/assets//img/clear.png" data-src="https://skift.com/wp-content/themes/skift-2021/assets//img/social-icons/mail.svg" width="24" alt="Email icon" /></button></li>
</ul>
</div>
<div class="footer-byline">
<div class="byline-wrap">
<p class="author-name"><a href="https://skift.com/author/sean-oneill/">Sean O'Neill</a>, Skift</p>
<p class="post-date">Today at 10:05 AM EST</p>
</div>
</div>
<p>Tags: <a href="https://skift.com/tag/coworking" class="no-red">coworking</a>, <a href="https://skift.com/tag/hospitality" class="no-red">hospitality</a>, <a href="https://skift.com/tag/hostels" class="no-red">hostels</a>, <a href="https://skift.com/tag/ipo" class="no-red">ipo</a>, <a href="https://skift.com/tag/selina" class="no-red">selina</a>, <a href="https://skift.com/tag/spacs" class="no-red">spacs</a>, <a href="https://skift.com/tag/startups-2" class="no-red">startups</a></p> <div class="photo-credit"><p>Photo credit: A view of a Selina property in Huaraz, Peru. Source: Skift</p></div>
</div>
<aside class="right-rail">
<div id="next-story-wrapper">
<div class="next-story"><em>Loading next story</em></div>
</div>
<div class="rail-meter hide-mobile">
<div class="odometer one-third">
<svg class="progress-ring" width="130" height="130">
<circle class="complete-ring" r="58" cx="65" cy="65" />
</svg>
<div class="text">
<span class="count">2</span>
Free stories left to read
</div>
</div>
<div class="rail-copy">
<p>Subscribe to Skift Pro to get unlimited access to stories like these ($25/month)</p>
<a href="https://skift.com/pro/" class="btn btn-black btn-sm">Subscribe Now</a>
</div>
</div> <div class="rail-ad-wrap hide-mobile"> <div class="rail-ad">
<div class="create-ad" data-size="300x250" data-mobilesize="300x250" data-slot="22809282/articleRail"></div>
</div>
</div>
<div id="editors-picks" class="story-list small lines-between">
<h3 class="text-center">Editor's Picks</h3>
<div class="stories">
<div class="story-wrap">
<div class="story-content">
<a href="https://skift.com/2021/11/29/hotel-industry-faces-omicron-variant-with-concerns-about-travel-bans/" class="story-link">
<p class="category">Coronavirus</p>
<h3>Hotel Industry Faces Omicron Variant With Concerns About Travel Bans</h3>
</a>
</div>
</div>
<div class="story-wrap">
<div class="story-content">
<a href="https://skift.com/2021/11/18/5-takeaways-from-skift-aviation-forum/" class="story-link">
<p class="category">Airlines</p>
<h3>5 Takeaways From Skift Aviation Forum</h3>
</a>
</div>
</div>
<div class="story-wrap">
<div class="story-content">
<a href="https://skift.com/2021/11/17/united-ceo-vows-to-beat-margin-leader-delta-on-quality-not-quantity/" class="story-link">
<p class="category">Airlines</p>
<h3>United CEO Vows to Beat Margin-Leader Delta on Quality not Quantity</h3>
</a>
</div>
</div>
<div class="story-wrap">
<div class="story-content">
<a href="https://skift.com/2021/11/04/airbnb-posts-best-quarter-ever-shattering-records-for-profits-and-revenue/" class="story-link">
<p class="category">Short-Term Rentals</p>
<h3>Airbnb Posts Best Quarter Ever, Shattering Records for Profits and Revenue</h3>
</a>
</div>
</div>
<div class="story-wrap">
<div class="story-content">
<a href="https://skift.com/2021/11/04/heres-what-stepping-up-on-climate-change-means-for-global-tourism/" class="story-link">
<p class="category">Tourism</p>
<h3>Here’s What Stepping Up on Climate Change Means for Global Tourism</h3>
</a>
</div>
</div>
</div>
</div> <div class="rail-ad-wrap hide-mobile"> <div class="rail-ad">
<div class="create-ad" data-size="300x250" data-mobilesize="300x250" data-slot="22809282/articleRailBottom"></div>
</div>
</div>
</aside>
</div>
</div>
<div class="row offset-1">
<div class="col-10 col-8-tablet col-4-mobile">
<div class="up-next">
<h2>Up Next</h2>
<div id="up-next"><em>Loading next stories</em></div>
</div>
</div>
</div> </section>
</article>
<section class="footer-meter">
<div class="row offset-3 offset-1-tablet">
<div class="col-6 col-6-tablet col-4-mobile text-center">
<h2>Subscribe to Skift Pro to get unlimited access to stories like these ($25/month)</h2>
<p>1 of 3 Free Stories Read</p>
<a href="https://skift.com/pro/" class="btn btn-black">Subscribe Now</a>
</div>
</div>
</section> </div>
<footer id="footer">
<div class="row offset-1">
<div class="col-10 col-8-tablet col-4-mobile">
<a href="https://skift.com"><img src="https://skift.com/wp-content/themes/skift-2021/assets/img/logo/logo-white.svg" width="75" class="footer-logo" alt="Skift Logo" /></a>
</div>
</div>
<div class="row offset-1">
<div class="col-5 col-4-tablet col-4-mobile">
<nav class="footer-nav">
<ul>
<li>
<input type="checkbox" id="travel-sections-toggle" class="accordian-toggle" />
<label for="travel-sections-toggle">Travel Sectors</label>
<ul>
<li><a href="https://skift.com/coronavirus/"><span></span>Coronavirus</a></li>
<li><a href="https://skift.com/tourism/"><span></span>Tourism</a></li>
<li><a href="https://skift.com/online-travel/"><span></span>Online Travel</a></li>
<li><a href="https://skift.com/hotels/"><span></span>Hotels</a></li>
<li><a href="https://skift.com/vacation-rentals/"><span></span>Vacation Rentals</a></li>
<li><a href="https://skift.com/airlines/"><span></span>Airlines</a></li>
<li><a href="https://skift.com/business-travel/"><span></span>Business Travel</a></li>
<li><a href="https://skift.com/meetings/"><span></span>Meetings</a></li>
<li><a href="https://skift.com/tour-operators/"><span></span>Tour Operators</a></li>
<li><a href="https://skift.com/all-categories/"><span></span>See All</a></li>
</ul>
</li>
<li>
<input type="checkbox" id="solutions-toggle" class="accordian-toggle" />
<label for="solutions-toggle">Skift Brands</label>
<ul>
<li><a href="https://eventmanagerblog.com" target="_blank" rel="noopener noreferrer"><span></span>EventMB</a></li>
<li><a href="https://airlineweekly.com" target="_blank" rel="noopener noreferrer"><span></span>Airline Weekly</a></li>
<li><a href="https://dailylodgingreport.com" target="_blank" rel="noopener noreferrer"><span></span>Daily Lodging Report</a></li>
<li><a href="https://research.skift.com" target="_blank" rel="noopener noreferrer"><span></span>Skift Research</a></li>
<li><a href="https://live.skift.com" target="_blank" rel="noopener noreferrer"><span></span>Skift Live</a></li>
</ul>
</li>
<li>
<input type="checkbox" id="about-skift-toggle" class="accordian-toggle" />
<label for="about-skift-toggle">About Skift</label>
<ul>
<li><a href="https://skift.com/about/"><span></span>About Skift</a></li>
<li><a href="https://skift.com/work-with-us/"><span></span>Work With Us</a></li>
<li><a href="https://skift.com/news-staff/"><span></span>News Staff</a></li>
<li><a href="https://skift.com/team/"><span></span>The Team</a></li>
<li><a href="https://skift.com/careers/"><span></span>Careers</a></li>
</ul>
</li>
</ul>
</nav>
</div>
<div class="col-5 col-4-tablet col-4-mobile right-column">
<h3 class="follow-us">Follow Us</h3>
<nav class="footer-social">
<ul>
<li><a href="https://facebook.com/skiftnews">Facebook</a></li>
<li><a href="https://www.instagram.com/skiftnews/">Instagram</a></li>
<li><a href="https://twitter.com/skift">Twitter</a></li>
<li><a href="https://linkedin.com/company/skift">LinkedIn</a></li>
<li><a href="https://skift.com/newsletters/">Email</a></li>
</nav>
<div class="footer-tweet">
<p class="tweet-content">
Kayak’s Hotels Partner Life House Receives $60 Million in New Financing <a href="https://t.co/43dy6kQB1n">https://t.co/43dy6kQB1n</a> </p>
<p class="tweet-meta">
Twitter | 43 mins ago </p>
</div>
</div>
</div>
<div class="row offset-1">
<div class="col-10 col-8-tablet col-4-mobile">
<ul class="copyright">
<li>&copy; 2021 Skift</li>
<li>All rights reserved</li>
<li><a href="https://skift.com/terms/">Terms of Service</a></li>
<li><a href="https://skift.com/privacy/">Privacy Policy</a></li>
</ul>
</div>
</div>
</footer><script type='text/javascript' src='https://skift.com/wp-content/themes/skift-2021/assets/scripts/vendor.js?ver=17d724fad8f' id='vendor-scripts-js'></script>
<script type='text/javascript' src='https://skift.com/wp-content/themes/skift-2021/assets/scripts/main.js?ver=17d724fad8f' id='main-scripts-js'></script>
<script data-cfasync="false" type='text/javascript' data-parsely-site="skift.com" src='https://cdn.parsely.com/keys/skift.com/p.js?ver=2.6.0' id="parsely-cfg"></script>
<script src='https://stats.wp.com/e-202148.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2',blog:'198915780',post:'456714',tz:'-5',srv:'skift.com'} ]);
	_stq.push([ 'clickTrackerInit', '198915780', '456714' ]);
</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WZ9FZL8"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6b7751157c5e5dbb',m:'eoCOdm5sDSlJjAXAY91eWGu3VemXQhyDmdZuPuJioMY-1638477070-0-AeF5QV0iGM9ybnP5hyQgVvaq+/8E5K1z+Vxh3wtdAvlpEvd1fB8hNIAIh3PMGTzvXtR/A1Po518onRNhVA1MOyvKCsBkf4ySz+l+oS6uBDeLgiC8jPsyiIbMopSnyeNfHrEE3OxldUWBRv+o1f3g0axbACXK+Qu6NryEDcbFOZXZq0Xz02vT9Zt7Oc41kMPYzNTWr1qhz4oFNW8vnlke2ewqJ+vpv9sAIhz0z06JAehq',s:[0x07a6ef4d65,0x15a7fa4555],}})();</script></body>
</html>